Срочно!! Паскаль!! Напишите программу которая определяет является ли заданное натуральное числом
квадратом некоторого натурального числаОтветы на вопрос
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
Конечно, вот пример программы на Pascal, которая определяет, является ли заданное натуральное число квадратом некоторого натурального числа:
```pascal program CheckSquare;
var inputNumber: integer;
begin // Вводим натуральное число write('Введите натуральное число: '); readln(inputNumber);
// Проверяем, является ли число квадратом некоторого натурального числа if (sqrt(inputNumber) = trunc(sqrt(inputNumber))) and (inputNumber > 0) then writeln(inputNumber, ' является квадратом некоторого натурального числа.') else writeln(inputNumber, ' не является квадратом некоторого натурального числа.');
end. ```
Программа использует функцию `sqrt`, которая возвращает квадратный корень числа, и функцию `trunc`, которая отбрасывает дробную часть числа. Если результат `sqrt` равен целой части результата, и введенное число больше 0, то программа выводит, что число является квадратом некоторого натурального числа, в противном случае выводится обратное утверждение.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
