
Написать программу возведения числа a в степень n.С циклом repeat или while.Даю 65 баллов


Ответы на вопрос

// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadReal('Введите число a:');
var n:=ReadInteger('Введите показатель степени n:');
if n<=0 then begin
Writeln('Показатель степени должен быть натуральным числом');
Exit
end;
// перевод показателя степени в двоичную систему счисления
var t:=n;
var r:string:='';
while t>=2 do (r,t):=(t mod 2+r,t shr 1);
r:=t+r;
// возведение в степень
var (rr,i):=(a,2);
while i<=r.Length do begin
rr:=Sqr(rr);
if r[i]='1' then rr*=a;
i+=1
end;
Writeln(a,'^',n,' = ',rr)
end.
Примеры
Введите число a: 3.182
Введите показатель степени n: 11
3.182^11 = 338611.675261463
Введите число a: 2
Введите показатель степени n: 10
2^10 = 1024



Program for Exponentiation Using a Repeat Loop
Here's a program written in Delphi that uses a repeat loop to calculate the exponentiation of a given number `a` raised to the power of `n`:
```delphi program Exponentiation; var a, result: real; n, i: integer; begin // Input the base number and the exponent write('Enter the base number (a): '); readln(a); write('Enter the exponent (n): '); readln(n);
// Initialize the result to 1 result := 1;
// Calculate the exponentiation using a repeat loop i := 1; repeat result := result * a; i := i + 1; until i > n;
// Output the result writeln('Result: ', result); end. ```
In this program, the user is prompted to enter the base number `a` and the exponent `n`. The program then initializes the `result` variable to 1 and uses a repeat loop to multiply `result` by `a` `n` times. Finally, the program outputs the result.
Please note that this program is written in Delphi, a programming language, and can be executed using a Delphi compiler or IDE.
I hope this helps! Let me know if you have any further questions.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili