Вопрос задан 08.05.2019 в 09:00.
Предмет Информатика.
Спрашивает Половий Сергей.
Помогите плиз по паскалю Амурам скучать не приходится: работы каждый день - хоть отбавляй! При этом
известно, что в одном колчане у Амура S стрел. Вчера Амур расстрелял K колчанов, а сегодня еще C стрел. Сколько полных колчанов расстрелял Амур за последние два дня? Формат входных данных S=2 K=8 C=4 Вводится 3 числа: количество стрел в одном колчане S ( S < LONGINT ), количество расстрелянных колчанов K ( K < LONGINT ) и количество расстрелянных стрел C ( C < LONGINT ). Формат выходных данных Вывести количество полных колчанов, расстрелянных Амуром за два дня.Ответы на вопрос
Отвечает Fox Just.
Var
s, k, c: int64;
begin
readln(s, k, c);
write(k + (c div s));
end.
s, k, c: int64;
begin
readln(s, k, c);
write(k + (c div s));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения данной задачи по паскалю, мы можем использовать простую математическую формулу. Давайте разберемся.
Входные данные:
У нас есть три числа: количество стрел в одном колчане (S), количество расстрелянных колчанов (K) и количество расстрелянных стрел (C).Задача:
Нам нужно вычислить количество полных колчанов, которые Амур расстрелял за последние два дня.Решение:
Для решения задачи, мы можем использовать следующую формулу:Количество полных колчанов = (K * S + C) / S
Давайте подставим значения из входных данных в эту формулу:
Количество полных колчанов = (8 * 2 + 4) / 2 = 20 / 2 = 10
Таким образом, Амур расстрелял 10 полных колчанов за последние два дня.
Надеюсь, это помогло! Если у вас есть еще вопросы, пожалуйста, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
