Вопрос задан 08.05.2019 в 08:46. Предмет Информатика. Спрашивает Коровина Дария.

Помогите написать программу на паскале.Надо чтобы введенное число оканчивалось на 7.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ярчук Аліна.
Var a:integer;
begin
repeat
  readln(a);
  if (a - (a div 10)*10) <> 7 then writeln ('неверно');
until (a - (a div 10)*10) = 7;
writeln(a);
end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Pascal, которая будет проверять, оканчивается ли введенное число на 7. Вот пример простой программы:

```pascal program CheckEndingSeven;

var inputNumber: integer;

begin // Введите число с клавиатуры write('Введите число: '); readln(inputNumber);

// Проверка, оканчивается ли число на 7 if inputNumber mod 10 = 7 then writeln('Число оканчивается на 7.') else writeln('Число не оканчивается на 7.');

// Ждем, пока пользователь нажмет клавишу перед выходом readln; end. ```

Давайте рассмотрим основные моменты программы:

1. `inputNumber` - переменная, в которую будет введено число с клавиатуры. 2. `write('Введите число: ');` - выводит приглашение для ввода числа. 3. `readln(inputNumber);` - считывает введенное число с клавиатуры. 4. `if inputNumber mod 10 = 7 then` - проверяет, оканчивается ли число на 7. 5. `writeln('Число оканчивается на 7.')` - выводит сообщение, если число оканчивается на 7. 6. `else writeln('Число не оканчивается на 7.');` - выводит сообщение, если число не оканчивается на 7. 7. `readln;` - ждет, пока пользователь нажмет клавишу перед выходом из программы.

Вы можете скомпилировать и выполнить эту программу с помощью вашего Pascal-компилятора. При вводе числа программа сообщит вам, оканчивается ли оно на 7.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос