 
Дан массив 3х4 с элементами целого типа. написать программу для вычисления количества элементов в
массиве, которые являются натуральными трехзначными числами. язык с/с++ 0
        0
         0
        0
    Ответы на вопрос
 
        int count = 0;
for(int i = 0; i <= 2; i++) {
for(int j = 0; j <= 3; j++) {
int tri = div(in[i][j], 100).quot;
if ( in[i][j] > 0 ) && ( tri >= 1 ) && ( tri < 10 ) {
count += 1;
}
}
}
return count;
}
 0
                    0
                     0
                    0
                 
            Для вычисления количества элементов в массиве, которые являются натуральными трехзначными числами, можно использовать следующую программу на языке C++:
```cpp
#include 
int main() { int array[3][4] = {{123, 456, 789, 10}, {111, 222, 333, 444}, {555, 666, 777, 888}}; int count = 0;
for (int i = 0; i < 3; i++) { for (int j = 0; j < 4; j++) { if (array[i][j] >= 100 && array[i][j] <= 999) { count++; } } }
std::cout << "Количество трехзначных чисел в массиве: " << count << std::endl;
return 0; } ```
В данной программе создается двумерный массив `array` размером 3x4 с элементами целого типа. Затем, с помощью двух вложенных циклов `for`, происходит перебор всех элементов массива. Если элемент является трехзначным числом (т.е. больше или равен 100 и меньше или равен 999), то переменная `count` увеличивается на 1. В конце программы выводится количество трехзначных чисел в массиве.
Примечание: В данном примере использована статическая инициализация массива для упрощения кода. В реальных ситуациях массив может быть заполнен данными из файла или введен с клавиатуры.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			