Вопрос задан 08.05.2019 в 04:43. Предмет Информатика. Спрашивает Абельченко Лиля.

Программу в паскале. Составить программу нахождения произведения положительных чисел одномерного

массива В(10), элементы которого задаются датчиком случайных чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мажухина Кристина.
Program foo;
var
b : array[1..10] of integer;
p : longint;
i : byte;

begin
randomize;
for i:=1 to 10 do begin
b[i] := random(51)-25;
write(b[i], ' ');
end;
writeln;
p := 1;
for i:=1 to 10 do
if b[i]>0 then p:= p*b[i];
writeln(p);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с написанием программы на Паскале. Вот один из возможных вариантов решения вашей задачи:

```pascal program ProductOfPositive; var B: array[1..10] of integer; // объявляем одномерный массив B из 10 целых чисел i, product: integer; // объявляем переменные i и product для цикла и результата begin randomize; // инициализируем датчик случайных чисел product := 1; // присваиваем начальное значение 1 для произведения for i := 1 to 10 do // цикл по всем элементам массива begin B[i] := random(21) - 10; // генерируем случайное число от -10 до 10 и записываем его в массив writeln('B[', i, '] = ', B[i]); // выводим элемент массива на экран if B[i] > 0 then // если элемент положительный product := product * B[i]; // умножаем его на произведение end; writeln('Произведение положительных чисел массива B равно ', product); // выводим результат на экран end. ```

Надеюсь, это поможет вам с вашей задачей. Если у вас есть еще вопросы, я буду рад ответить на них.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос