 
Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов. Заполнить его
датчиком случайных чисел. Найти сумму отрицательных элементов. 0
        0
         0
        0
    Ответы на вопрос
 
        begin
var a:=ArrRandom(30,-20,20); a.Println;
Writeln('s=',a.Where(x->x<0).Sum)
end.
Тестовое решение:
7 9 9 -17 -20 -4 -16 4 -1 2 20 -5 -14 -1 10 -11 14 -12 -14 10 9 18 9 -18 3 16 7 -11 17 -10
s=-154
 0
                    0
                     0
                    0
                 
            Задача: Найти сумму отрицательных элементов в массиве
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет заполнять массив случайными числами и находить сумму отрицательных элементов.
Вот пример решения данной задачи на языке Pascal:
```pascal program SumOfNegativeElements;
const N = 30;
var arr: array[1..N] of integer; i, sum: integer;
begin Randomize;
// Заполняем массив случайными числами for i := 1 to N do begin arr[i] := Random(201) - 100; // Генерируем случайное число от -100 до 100 end;
// Находим сумму отрицательных элементов sum := 0; for i := 1 to N do begin if arr[i] < 0 then begin sum := sum + arr[i]; end; end;
// Выводим результат writeln('Сумма отрицательных элементов: ', sum);
end. ```
В данном примере программа создает массив `arr` из 30 элементов и заполняет его случайными числами от -100 до 100. Затем программа находит сумму отрицательных элементов массива и выводит результат.
Примечание: Для работы с генерацией случайных чисел используется функция `Randomize` для инициализации генератора случайных чисел и функция `Random(201) - 100` для генерации случайного числа от -100 до 100.
Надеюсь, это поможет вам решить задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			