Вопрос задан 14.05.2018 в 17:55.
Предмет Информатика.
Спрашивает Романова Валерия.
Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не
превосходящего 1000000000Ответы на вопрос
Отвечает Голубева Настя.
Function kr(n:longint):integer;
var
s:string;
begin
Str(Abs(n),s);
kr:=Length(s)
end;
var
k:longint;
begin
Write('Введите целое число: '); Read(k);
Writeln('В этом числе количество разрядов равно ',kr(k))
end.
Пример работы программы
Введите целое число: 1234567
В этом числе количество разрядов равно 7
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
