Вопрос задан 06.05.2019 в 15:58. Предмет Информатика. Спрашивает Савина Женя.

Написать программу. Задано натуральное число. Определить делится ли оно на два. Примечание:

проверка делимости на 2 осуществляется следующим образом: пусть N-натуральное число. Если N/2=N\2,то число делится на 2, иначе нет. (N/2-обычное деление, N\2-деление нацело)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кашин Илья.

вообще признак делимости на 2 можно определить проще. Если остаток от деления на 2=0 тогда число делится на 2 нацело иначе нет if (n mod 2)=0  then writeln('Число  делится на 2 нацело' ) else   writeln('Число не  делиться на 2 нацело' );

Однако если по условию задачи признак, такой то уж ничего не пделаешь 

Program evenNum;

Uses crt;

var n:real;

begin

     clrscr; 

 

     write('Введите число n: ');

     readln(n); 

 

     if ((n/2)<>(n div 2)) then writeln('Число не делится на 2 нацело' )

                 else   writeln('Число  делится на 2 нацело' ); 

    readkey;    

 

end. 

 

 

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я попробую написать программу, которая решает задачу, которую вы задали. Вот мой код на языке Python:

```python # Задано натуральное число n = int(input("Введите натуральное число: "))

# Определить делится ли оно на два if n / 2 == n // 2: # Если N/2=N\2, то число делится на 2 print("Число", n, "делится на 2") else: # Иначе нет print("Число", n, "не делится на 2") ```

Я надеюсь, что это поможет вам.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос