Вопрос задан 06.05.2019 в 12:45. Предмет Информатика. Спрашивает Рогулин Егор.

Написать программу в паскаль.Из всех двузначных чисел вывести на экран те из них, сумма цифр

которых равна А. (А вводится с клавиатуры)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Котова Екатерина.
Var
a,i:integer;
begin
write('A=');
readln(a);
for i:=10 to 99 do
if (i div 10)+(i mod 10) = a then
writeln(i);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Pascal для вывода двузначных чисел, сумма цифр которых равна А

Вот пример программы на Pascal, которая выводит на экран все двузначные числа, сумма цифр которых равна заданному числу А. Число А вводится с клавиатуры.

```pascal program TwoDigitNumbers;

var A, i, digit1, digit2, sum: integer;

begin // Ввод числа А с клавиатуры write('Введите число А: '); readln(A);

// Проверка и вывод двузначных чисел, сумма цифр которых равна А writeln('Двузначные числа, сумма цифр которых равна ', A, ':'); for i := 10 to 99 do begin digit1 := i div 10; // Первая цифра числа digit2 := i mod 10; // Вторая цифра числа sum := digit1 + digit2; // Сумма цифр числа

if sum = A then writeln(i); end; end. ```

Программа начинается с объявления переменных. Затем пользователю предлагается ввести число А с клавиатуры. Далее, с помощью цикла `for`, программа проверяет все двузначные числа от 10 до 99. Для каждого числа, программа вычисляет сумму его цифр и сравнивает ее с числом А. Если сумма равна А, то число выводится на экран.

Пример работы программы:

``` Введите число А: 7 Двузначные числа, сумма цифр которых равна 7: 16 25 34 43 52 61 70 ```

Примечание: Приведенная программа решает задачу, но может быть оптимизирована для улучшения производительности.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос