Вопрос задан 06.05.2019 в 02:48. Предмет Информатика. Спрашивает Шикуть Мария.

Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных в одномерный

целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность массива).Заменить последний элемент массива минимальным (10)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мелихова Варвара.
Var
  i,min:integer;
  a:array[1..10]of integer;
begin
i:=1;
while i<11 do
  begin
  readln(a[i]);
  if i=1 then min:=a[1];
  if a[i]<min then min:=a[i];
  i:=i+1;
  end;
writeln('Исходный массив:');
i:=1;
repeat
  write(a[i],' ');
  i:=i+1;
  until i>10;
a[10]:=min;
writeln;
writeln('Измененный массив:');
i:=1;
repeat
  write(a[i],' ');
  i:=i+1;
  until i>10;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Pascal ABC, которая вводит данные в одномерный целочисленный массив с использованием цикла `while...do`, а вывод осуществляется с помощью цикла `repeat...until`. В данной программе также заменяется последний элемент массива на минимальное значение (10):

```pascal program ArrayInputOutput; var arr: array of Integer; size, i, minIndex: Integer; begin // Ввод размерности массива write('Введите размерность массива: '); readln(size);

// Инициализация массива SetLength(arr, size);

// Ввод элементов массива writeln('Введите элементы массива:'); i := 0; while i < size do begin write('Элемент ', i + 1, ': '); readln(arr[i]); i := i + 1; end;

// Поиск индекса минимального элемента minIndex := 0; for i := 1 to size - 1 do begin if arr[i] < arr[minIndex] then minIndex := i; end;

// Замена последнего элемента на минимальное значение arr[size - 1] := 10;

// Вывод элементов массива writeln('Элементы массива:'); i := 0; repeat writeln(arr[i]); i := i + 1; until i = size; end. ```

Обратите внимание на следующие моменты: - Программа запрашивает у пользователя размерность массива и затем вводит элементы массива. - Затем программа находит индекс минимального элемента в массиве и заменяет последний элемент на значение 10. - Наконец, программа выводит все элементы массива.

Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос