Написать программу в Паскале: Заяц в первый день пробегает 40 км, во второй день на 3 км больше.
Вывести ответ, сколько км заяц пробежит за 7 дней.Ответы на вопрос
begin
writeln(40+3*6,' km probejit zayac za 7 dnei');
readln;
end;
Для решения этой задачи в Паскале, мы можем использовать цикл и накопление данных. Вот пример программы на Паскале, которая решает данную задачу:
```pascal program RabbitDistance;
var day: Integer; // переменная для хранения номера дня distance: Integer; // переменная для хранения пройденного расстояния totalDistance: Integer; // переменная для хранения общего пройденного расстояния
begin distance := 40; // пройденное расстояние в первый день totalDistance := distance; // инициализация общего пройденного расстояния
for day := 2 to 7 do // цикл для остальных шести дней begin distance := distance + 3; // увеличиваем пройденное расстояние на 3 км каждый день totalDistance := totalDistance + distance; // добавляем пройденное расстояние к общему пройденному расстоянию end;
writeln('Заяц пробежит за 7 дней: ', totalDistance, ' км'); // выводим общее пройденное расстояние end. ```
После выполнения программы, она выведет общее пройденное расстояние зайца за 7 дней. В данном случае, ответ будет зависеть от исходного расстояния в первый день (40 км) и увеличения расстояния на 3 км каждый последующий день.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
