Для каждой задачи составить программу в Pascal, выводящую значение TRUE, если указанное
высказывание является истинным, и FALSE - в противном случае (использовать условный оператор нельзя).10. В заданном натуральном трехзначном числе N имеется чётная цифра.11. Сумма каких-либо двух цифр заданного трёхзначного натурального числа N равна третьей цифре.12. Сумма цифр заданного четырёхзначного числа N превосходит произведение цифр этого же числа на 1.13. Сумма двух последних цифр заданного трёхзначного числа N меньше заданного K, а первая цифра больше 5.Ребята, очень прошу, помогите! Срочно!!!Ответы на вопрос
var
n: integer;
begin
read(n);
Write((n div 100 mod 2 = 0) or (n mod 10 mod 2 = 0) or (n mod 100 div 10 mod 2 = 0));
end.
// 11.
var
n: integer;
a,b,c:integer;
begin
read(n);
a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
Write((a+b=c)or(a+c=b)or(c+b=a));
end.
// 12.
var
n: integer;
a,b,c,d:integer;
begin
read(n);
a:=n div 1000; b:=n mod 1000 div 10 div 10; c:=n mod 100 div 10; d:=n mod 10;
Write(a+b+c+d-1=a*b*c*d);
end.
// 13.
var
n,k: integer;
a,b,c:integer;
begin
Write('n,k= '); read(n,k);
a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
Write((b+c<k)and(a>5));
end.
Задача 10: В заданном натуральном трехзначном числе N имеется четная цифра.
Для решения этой задачи вам потребуется разложить трехзначное число на отдельные цифры и проверить, есть ли среди них четная цифра. Если есть, то программа должна вывести значение TRUE, иначе - FALSE.
Вот пример программы на языке Pascal, которая решает данную задачу:
```pascal program Task10; var N: integer; digit: integer; begin write('Введите трехзначное число N: '); readln(N); digit := N mod 10; // последняя цифра числа N if (digit mod 2 = 0) then writeln('TRUE') else writeln('FALSE'); end. ```
Программа сначала запрашивает трехзначное число N у пользователя. Затем она находит последнюю цифру числа N с помощью операции остатка от деления на 10. Если эта цифра является четной (то есть делится на 2 без остатка), то программа выводит TRUE. В противном случае программа выводит FALSE.
Задача 11: Сумма каких-либо двух цифр заданного трехзначного натурального числа N равна третьей цифре.
Для решения этой задачи вам также потребуется разложить трехзначное число на отдельные цифры и проверить, существует ли такая пара цифр, сумма которых равна третьей цифре. Если такая пара существует, то программа должна вывести значение TRUE, иначе - FALSE.
Вот пример программы на языке Pascal, которая решает данную задачу:
```pascal program Task11; var N: integer; digit1, digit2, digit3: integer; begin write('Введите трехзначное число N: '); readln(N); digit1 := N div 100; // первая цифра числа N digit2 := (N div 10) mod 10; // вторая цифра числа N digit3 := N mod 10; // третья цифра числа N if ((digit1 + digit2 = digit3) or (digit1 + digit3 = digit2) or (digit2 + digit3 = digit1)) then writeln('TRUE') else writeln('FALSE'); end. ```
Программа сначала запрашивает трехзначное число N у пользователя. Затем она разбивает число N на отдельные цифры, используя операции деления и остатка от деления. Затем программа проверяет все возможные комбинации сумм двух цифр и сравнивает их с третьей цифрой. Если хотя бы одна комбинация совпадает, то программа выводит TRUE. В противном случае программа выводит FALSE.
Задача 12: Сумма цифр заданного четырехзначного числа N превосходит произведение цифр этого же числа на 1.
Для решения этой задачи вам также потребуется разложить четырехзначное число на отдельные цифры и сравнить их сумму с произведением цифр. Если сумма цифр больше произведения, то программа должна вывести значение TRUE, иначе - FALSE.
Вот пример программы на языке Pascal, которая решает данную задачу:
```pascal program Task12; var N: integer; digit1, digit2, digit3, digit4: integer; sum, product: integer; begin write('Введите четырехзначное число N: '); readln(N); digit1 := N div 1000; // первая цифра числа N digit2 := (N div 100) mod 10; // вторая цифра числа N digit3 := (N div 10) mod 10; // третья цифра числа N digit4 := N mod 10; // четвертая цифра числа N sum := digit1 + digit2 + digit3 + digit4; product := digit1 * digit2 * digit3 * digit4; if (sum > product) then writeln('TRUE') else writeln('FALSE'); end. ```
Программа сначала запрашивает четырехзначное число N у пользователя. Затем она разбивает число N на отдельные цифры, используя операции деления и остатка от деления. Затем программа вычисляет сумму и произведение цифр числа N. Затем она сравнивает сумму с произведением и выводит TRUE, если сумма больше произведения, и FALSE в противном случае.
Задача 13: Сумма двух последних цифр заданного трехзначного числа N меньше заданного K, а первая цифра больше 5.
Для решения этой задачи вам также потребуется разложить трехзначное число на отдельные цифры и сравнить их сумму с заданным числом K. Также нужно проверить, что первая цифра больше 5. Если оба условия выполняются, то программа должна вывести значение TRUE, иначе - FALSE.
Вот пример программы на языке Pascal, которая решает данную задачу:
```pascal program Task13; var N, K: integer; digit1, digit2, digit3: integer; sum: integer; begin write('Введите трехзначное число N: '); readln(N); write('Введите число K: '); readln(K); digit1 := N div 100; // первая цифра числа N digit2 := (N div 10) mod 10; // вторая цифра числа N digit3 := N mod 10; // третья цифра числа N sum := digit2 + digit3; if ((sum < K) and (digit1 > 5)) then writeln('TRUE') else writeln('FALSE'); end. ```
Программа сначала запрашивает трехзначное число N и число K у пользователя. Затем она разбивает число N на отдельные цифры, используя операции деления и остатка от деления. Затем программа вычисляет сумму двух последних цифр числа N. Затем она проверяет, что сумма меньше K и первая цифра больше 5. Если оба условия выполняются, то программа выводит TRUE, иначе - FALSE.
Надеюсь, эти программы помогут вам решить задачи! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
