
Вопрос задан 13.05.2018 в 21:15.
Предмет Информатика.
Спрашивает Кенаев Даниил.
Составьте программу. Для вводимых с клавиатуры чисел определить количество положительных. ввод
чисел прекращается, когда пользователь вводит 0.

Ответы на вопрос

Отвечает Осипова Софья.
Var a,k:integer;
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili