Напишите программу в паскале,что бы Найти сумму членов арифметической прогрессии, если известны
первый член,разность и число членов прогрессии.Ответы на вопрос
Var a,b,c,s,i:integer;
Begin
Write('Введите первый член прогрессии: ');
Readln(a);
Write('Введите разность чисел прогрессии: ');
Readln(b);
Write('Введите количество чисел прогрессии: ');
Readln(c);
for i:=1 to c do
Begin
s:=s+a;
a:=a+b;
End;
Writeln('Сумма членов прогрессии: ',s);
End.
Конечно! Вот пример программы на языке Pascal, которая будет находить сумму членов арифметической прогрессии на основе заданных данных:
```pascal program СуммаАрифметическойПрогрессии;
var первыйЧлен, разность, числоЧленов, сумма: integer; текущийЧлен: integer;
begin // Ввод данных writeln('Введите первый член арифметической прогрессии: '); readln(первыйЧлен);
writeln('Введите разность арифметической прогрессии: '); readln(разность);
writeln('Введите число членов арифметической прогрессии: '); readln(числоЧленов);
// Вычисление суммы сумма := 0; текущийЧлен := первыйЧлен;
for i := 1 to числоЧленов do begin сумма := сумма + текущийЧлен; текущийЧлен := текущийЧлен + разность; end;
// Вывод результата writeln('Сумма членов арифметической прогрессии: ', сумма); end. ```
Вы можете скопировать эту программу в свою среду разработки Pascal и запустить ее, чтобы найти сумму членов арифметической прогрессии.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
