
Написать программу на языке Си .1. Подсчитать количество прописных букв в строке. 2. Удалить из
строки самое длинное слово.

Ответы на вопрос

Код C++
#include <conio.h>
#include <stdio.h>
#include <string.h>
#include <iostream.h>
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<<endl<<endl;
gets(s);
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<<endl<<g<<endl;
if(a<g)
{a=g;
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<<endl<<e;
getch();
}



Вот пример программы на языке C, которая выполняет две задачи:
```c
#include
int countUpperCase(char* str) { int count = 0; for (int i = 0; i < strlen(str); i++) { if (isupper(str[i])) { count++; } } return count; }
void removeLongestWord(char* str) { char* longestWord = ""; char* word = strtok(str, " "); while (word != NULL) { if (strlen(word) > strlen(longestWord)) { longestWord = word; } word = strtok(NULL, " "); } char* temp = strstr(str, longestWord); if (temp != NULL) { memmove(temp, temp + strlen(longestWord) + 1, strlen(temp + strlen(longestWord) + 1) + 1); } }
int main() { char str[100]; printf("Enter a string: "); fgets(str, sizeof(str), stdin); int upperCaseCount = countUpperCase(str); printf("Number of uppercase letters: %d\n", upperCaseCount); removeLongestWord(str); printf("String after removing longest word: %s\n", str); return 0; } ```
Эта программа сначала запрашивает у пользователя ввести строку. Затем она вызывает функцию `countUpperCase`, чтобы подсчитать количество прописных букв в строке, и функцию `removeLongestWord`, чтобы удалить самое длинное слово из строки. В конце программа выводит количество прописных букв в строке и измененную строку после удаления самого длинного слова.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili