Помогите с программой в Паскале, пожалуйста!! Дан массив из N чисел. Определить количество чисел,
превышающих число 5. Найти сумму этих чисел.Напишите программу.. (одномерный массив)Ответы на вопрос
var
ar : array[1..100] of Integer;
i, size, count, sum : Integer;
begin
Writeln('Введите размер массива');
Readln(size);
if (size > 100) then begin
Writeln('Hазмер массива превышает 100 элементов. Программа будет завершена...');
Readln;
end
else begin
Writeln('Введите ', size, ' чисел');
for i:=1 to size do begin
readln(ar[i]);
if ar[i] > 5 then begin
Inc(count);
Inc(sum, ar[i]);
end;
end;
Writeln('Вы ввели ', i - 1, ' чисел из которых ', count, ' больше 5, а их сумма составляет ', sum);
Readln;
end;
end.
Конечно, я могу помочь вам с программой на Паскале для решения данной задачи. Вот пример программы:
```pascal program CountAndSum; uses crt;
const N = 10; // Задайте размер массива здесь
var arr: array[1..N] of Integer; i, count, sum: Integer;
begin clrscr; // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to N do begin write('Элемент ', i, ': '); readln(arr[i]); end; // Подсчет количества чисел, превышающих 5, и их суммы count := 0; sum := 0; for i := 1 to N do begin if arr[i] > 5 then begin count := count + 1; sum := sum + arr[i]; end; end; // Вывод результатов writeln('Количество чисел, превышающих 5: ', count); writeln('Сумма этих чисел: ', sum); readln; end. ```
В данной программе мы сначала объявляем массив `arr` размером `N`, где `N` - это количество чисел в массиве. Затем мы заполняем массив вводом с клавиатуры. Далее мы проходим по всем элементам массива и считаем количество чисел, превышающих 5, и их сумму. Наконец, выводим результаты на экран.
Обратите внимание, что в данном примере размер массива задан константой `N`. Вы можете изменить значение `N` в соответствии с вашими потребностями.
Надеюсь, эта программа поможет вам решить задачу. Если у вас возникнут еще вопросы, не стесняйтесь задавать их!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
