В Паскале написать программу: чтобы там вводилась строка, например 'мама мыла раму'. В этой строке
нужно найти 2 слово и заменить его на любую согласную букву. Помогите пожалуйста!!!! 20 бОтветы на вопрос
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString.ToWords;
s[1]:='в'; s.Println
end.
Пример
мама мыла раму
мама в раму
Программа на языке Pascal для замены второго слова в строке
Вот пример программы на языке Pascal, которая позволяет ввести строку и заменить второе слово на любую согласную букву:
```pascal program ReplaceWord;
uses SysUtils;
var inputString: string; words: TStringDynArray; consonant: char;
begin // Ввод строки Write('Введите строку: '); ReadLn(inputString);
// Разделение строки на слова words := SplitString(inputString, ' ');
// Проверка, что в строке есть хотя бы два слова if Length(words) < 2 then begin WriteLn('В строке должно быть хотя бы два слова.'); Exit; end;
// Замена второго слова на согласную букву Write('Введите согласную букву: '); ReadLn(consonant);
words[1] := consonant;
// Вывод измененной строки WriteLn('Измененная строка: ', JoinString(words, ' ')); end. ```
Программа сначала запрашивает у пользователя ввод строки. Затем она разделяет строку на слова и проверяет, что в строке есть хотя бы два слова. После этого программа запрашивает у пользователя ввод согласной буквы и заменяет второе слово на эту букву. Наконец, программа выводит измененную строку.
Примечание: В этой программе не выполняется проверка на то, что введенный символ действительно является согласной буквой. Если введенный символ не является согласной буквой, программа может работать некорректно.
Надеюсь, эта информация будет полезной! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
