Вопрос задан 30.04.2019 в 05:51. Предмет Информатика. Спрашивает Белая Анна.

Программирование, Паскаль, Посчитать сумму ряда от 3 до N чисел, кратных 3.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Николаев Илья.
П.с. если уровень 10-11 класс, то думаю, что решить необходимо с использованием массива. В приложениях смотри ответ.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам потребуется написать программу на языке программирования Паскаль. Программа будет выглядеть примерно так:

```pascal program SumOfMultiplesOfThree;

var N, i, sum: integer;

begin sum := 0; write('Enter the value of N: '); readln(N); for i := 3 to N do begin if i mod 3 = 0 then sum := sum + i; end; writeln('The sum of multiples of 3 from 3 to ', N, ' is: ', sum); end. ```

Эта программа начинается с объявления переменных N, i и sum, которые будут использоваться для хранения значения N, текущего числа в цикле и суммы чисел соответственно.

Затем программа запрашивает у пользователя ввести значение N. После этого программа использует цикл for для перебора чисел от 3 до N и проверяет, делится ли текущее число на 3 без остатка. Если да, то это число добавляется к сумме.

Наконец, программа выводит на экран сумму всех чисел, кратных 3, от 3 до N.

Вы можете скомпилировать и запустить эту программу на своем компьютере, чтобы убедиться, что она работает правильно.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос