Вопрос задан 27.04.2019 в 06:35.
Предмет Информатика.
Спрашивает Гончарова Мария.
В Pascal ABC составить программу: Вводится слово. Определяется, заканчивается-ли это слово на "ра".
Если слово заканчивается на "ра" - дописать к нему в конце "л" и вывести его значение на экран. Если слово не заканчивается на "ра" - вывести его на экран.Ответы на вопрос
Отвечает Лычкина Яна.
Не совсем понял, какое слово нужно вывести на экран..
public class MainClass
{
public static void main (String[]args)
{
System.out.println("нужное слово");
}
}
Извиняюсь, если что-то неправильно..Это должно быть Pascal или Java..
public class MainClass
{
public static void main (String[]args)
{
System.out.println("нужное слово");
}
}
Извиняюсь, если что-то неправильно..Это должно быть Pascal или Java..
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на Pascal ABC:
```pascal program CheckWordEnding;
var word: string;
begin writeln('Введите слово:'); readln(word);
if Copy(word, Length(word) - 1, 2) = 'ра' then begin word := word + 'л'; writeln('Слово с добавленной буквой "л": ', word); end else begin writeln('Слово без изменений: ', word); end; end. ```
Эта программа сначала запрашивает у пользователя ввод слова. Затем она проверяет, заканчивается ли введенное слово на "ра". Если это так, то к слову добавляется буква "л" в конце, и новое слово выводится на экран. Если слово не заканчивается на "ра", то оно просто выводится на экран без изменений.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 40
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
