Вопрос задан 12.05.2018 в 13:03.
Предмет Информатика.
Спрашивает Худяков Вова.
Дан массив из 20 натуральных чисел. Составить программу суммы элементов, кратных данному числу d .
Ответы на вопрос
Отвечает Рудакова Арина.
Const
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
