Вопрос задан 25.04.2019 в 02:47. Предмет Информатика. Спрашивает Гаврилова Даша.

1составьте программу ,вычисляющую сумму кубов первых n натуральных чисел2Туристы в 1-ый день прошли

7км.В каждый следующий день они проходили на 1.5 км > .Составь программу ,вычисляющую сколько километров они пройдут за n дней.Помогите срочно ,пожалуйста )))
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Алиев Марсель.
1
const
n = 100;
var
a: array[1..n] of word;
i, m: byte;
sum: word;
begin
write('Kol-vo chisel: ');
readln(m);
sum:=0;
for i:=1 to m do   
begin   
a[i] := i;   
write(a[i]:4);   
sum:=sum + sqr(a[i])*a[i];   
end;   
writeln;   
writeln('Sum = ', sum:4);  
readln;
end.

2
const
n = 100;
var
a: array[1..n] of word;
i, dn: byte;
km: real;
begin
write('Kol-vo dney: ');
readln(dn);
km:=7;
for i:=2 to dn do   
km:=km+(km+1.5);
writeln;
writeln('Turisty proshli ', km:4:1, ' km');
readln;
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос