Вопрос задан 24.04.2019 в 19:35. Предмет Информатика. Спрашивает Кутепова Валентина.

ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!нужно написать программу, которая по вводу с клавиатуры

последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое НЕЧЕТНЫХ чисел и чисел, КРАТНЫХ 5.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Исаков Роман.
Var x,i:integer;
   y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then 
Begin  i:=i+1; 
 y:=x+y; 
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.
0 0
Отвечает Мокрынська Мирослава.
Var
   A,i:integer;
   B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
 Begin
  i:=i+1;
  B:=A+B;
 End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос