Вопрос задан 11.05.2018 в 00:08. Предмет Информатика. Спрашивает Костюкевич Женя.

Написать программу в на языке Pascal. По желанию помочь понять, что в моем коде не так: var a, b,

c, s, k, y:real; begin writeln('Введите числа a,b,c'); readln(a, b, c); s :=(sqrt(a + b*b*b*b*b))/(3 * c); k :=s - (sqrt(abs(a * b * c))); y :=(s + k) - (s/(b*c)); writeln('y= ',y); end. (человека, который поможет отмечу лучшим)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сокот Богдан.

При таком наборе данных при вычислении значения s получается корень квадратный из отрицательного числа -29. Поэтому программа и выдает сообщение : Не число.
Набор данных некорректен.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос