Вопрос задан 14.04.2019 в 22:53.
Предмет Информатика.
Спрашивает Лоскутов Александр.
Даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник
с такими длинами сторон. Если такой существует , то определите его тип (равносторонний , равнобедренный, разносторонний) СРОЧНО! ЗАРАНЕЕ СПАСИБО.Ответы на вопрос
Отвечает Морозов Кирилл.
Var
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(a<>c))or((c=b)and(c<>a))or((c=a)and(c<>b)))and (k=1) then
writeln('равнобедренный');
if (a<>b)and(c<>b)and(a<>c)and (k=1) then
writeln('разносторонний')
end.
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(a<>c))or((c=b)and(c<>a))or((c=a)and(c<>b)))and (k=1) then
writeln('равнобедренный');
if (a<>b)and(c<>b)and(a<>c)and (k=1) then
writeln('разносторонний')
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
