Вопрос задан 12.04.2019 в 00:22.
Предмет Информатика.
Спрашивает Федотова Анастасия.
Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать
программу, которая определяет составное или простое число на входе и выводит сумму его цифр.Я написал первую часть программы (без вывода суммы цифр) :program sg3;uses crt;var i,a,k: integer;beginclrscr;write('Введите число: ');readln(a);k:=0;for i:=2 to a div 2 doif a mod i =0 then k:=k+1;if k=0 then write('Простое')else writeln('Составное');readln;end.Допишите пожалуйста код, который бы выводил сумму цифр,ПаскальОтветы на вопрос
Отвечает Даражадин Әсет.
Program sg3;
uses crt;
var i,a,k, sum: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then
k:=k+1;
if k=0 then
write('Простое')
else
writeln('Составное');
while (a<>0) do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
write('Сумма цифр= ',sum);
end.
uses crt;
var i,a,k, sum: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then
k:=k+1;
if k=0 then
write('Простое')
else
writeln('Составное');
while (a<>0) do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
write('Сумма цифр= ',sum);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
