Вопрос задан 06.04.2019 в 16:13.
Предмет Информатика.
Спрашивает Сивонина Кристина.
Составьте программу нахождения количества слов в предложении. Предложение состоит из слов,
отделенных друг от друга одним пробелом. Предложение вводится с клавиатуры.Ответы на вопрос
Отвечает Смык Максим.
Program Task;
Var s: String;
i, r: Integer;
Begin
WriteLn('Введите предложение:');
ReadLn(s);
If (Length(s) > 0) And (s[1] <> ' ') Then
r := 1;
For i := 1 To Length(s) Do
If s[i] = ' ' Then
r := r + 1;
WriteLn('Результат: ', r);
ReadLn;
End.
Var s: String;
i, r: Integer;
Begin
WriteLn('Введите предложение:');
ReadLn(s);
If (Length(s) > 0) And (s[1] <> ' ') Then
r := 1;
For i := 1 To Length(s) Do
If s[i] = ' ' Then
r := r + 1;
WriteLn('Результат: ', r);
ReadLn;
End.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
