Вопрос задан 27.03.2019 в 14:43. Предмет Информатика. Спрашивает Буркова Женя.

Написать программу, которая: 1. Дано вещественное число x, посчитать функцию, возвращающую y=f(x),

если 2. F(x) = 2*x, при x < 0; 3. F(x) = 0, при x = 0; 4. F(x) = x*x + 10, при x> 0; Написать программу, которая: 1. Просит ввести год рождения человека; 2. Проверяет введенное значение (несколько параметров); 3. Вычисляет возраст человека; 4. Выводит на экран возраст и какую-либо характеристику (несколько параметров в зависимости от возраста в трех диапазонах).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Березенко Валерия.
#include <iostream>
#include <conio.h>

float mathFunc(float x) {
if (x < 0)
return 2 * x;
else if (x > 0)
return x * x + 10;
return 0;
}

int main() {
setlocale(LC_ALL, "");

std::cout << mathFunc(-1) << " " << mathFunc(0) << " " << mathFunc(1);//проверка

_getch();
return 0;
}
//1

#include <iostream>
#include <conio.h>

int main() {
setlocale(LC_ALL, "");

int year;
while (true) {
system("cls");
std::cout << "Введите год своего рождения:";
std::cin >> year;//год может быть отрицательным => до н.э.

year = 2017 - year;

printf("Вам %d лет,", year);

if (year < 45)
printf("вы молоды");
else if (year < 60)
printf("вы среднего возраста");
else if (year < 75)
printf("вы пожилого возраста");
else if (year > 90)
printf("вы старческого возраста");

_getch();
return 0;
}
//2

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос