 
Вопрос задан 15.03.2019 в 00:24.
Предмет Информатика.
Спрашивает Обуховський Олексій.
Помогите надо написать задачу на Паскале В заданном массиве определите количество
элементов,которые меньше заданного с клавиатуры числа 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Красная Маша.
                
     Const
n=10;
var
i,m,k:integer;
a:array[1..n] of integer;
begin
Randomize;
Write('Исходный массив: ');
for i:=1 to n do begin a[i]:=Random(90)+10; Write(a[i],' ') end;
Writeln;
Writeln('Введите целое число: '); Read(m);
k:=0;
for i:=1 to n do
if a[i]<m then Inc(k);
Writeln('Количество чисел, меньших ',m,' равно ',k)
end.
Тестовое решение:
Исходный массив: 42 89 49 25 96 87 94 93 41 28
Введите целое число:
50
Количество чисел, меньших 50 равно 5
                                        n=10;
var
i,m,k:integer;
a:array[1..n] of integer;
begin
Randomize;
Write('Исходный массив: ');
for i:=1 to n do begin a[i]:=Random(90)+10; Write(a[i],' ') end;
Writeln;
Writeln('Введите целое число: '); Read(m);
k:=0;
for i:=1 to n do
if a[i]<m then Inc(k);
Writeln('Количество чисел, меньших ',m,' равно ',k)
end.
Тестовое решение:
Исходный массив: 42 89 49 25 96 87 94 93 41 28
Введите целое число:
50
Количество чисел, меньших 50 равно 5
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			