
Вопрос задан 14.03.2019 в 11:48.
Предмет Информатика.
Спрашивает Butikov Daniil.
Дан массив из n элементов. Необходимо вывести количество элементов, которые больше своих «соседей»
(следующего и предыдущего элементов). Формат входных данных С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа целые и по модулю не превосходят 100. Формат выходных данных В качестве ответа выведите единственное число — количество искомых элементов.

Ответы на вопрос

Отвечает Гайсанов Ахмед.
//Dev-C++ 5.11 (C)
#include <stdio.h>
int main(void)
{int arr[100],n,k;
scanf("%d",&n);
k=0;
for(int i=0;i<n;i++)
scanf("%d",&arr[i]);
for(int i=0;i<n;i++)
if(i==0 && arr[i]>arr[i+1])k++;
else
if(i==n-1 && arr[i]>arr[i-1])k++;
else
if(arr[i]>arr[i-1] && arr[i]>arr[i+1])k++;
printf("%d",k);
return 0;}
#include <stdio.h>
int main(void)
{int arr[100],n,k;
scanf("%d",&n);
k=0;
for(int i=0;i<n;i++)
scanf("%d",&arr[i]);
for(int i=0;i<n;i++)
if(i==0 && arr[i]>arr[i+1])k++;
else
if(i==n-1 && arr[i]>arr[i-1])k++;
else
if(arr[i]>arr[i-1] && arr[i]>arr[i+1])k++;
printf("%d",k);
return 0;}


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili