Кто хорошо разбирается в программировании? очень нужно :) Помогите пожалуйста, напишите программы в
Паскале для задач: 1. Заполнить массив А[15] числами 106, 112, 118, 124, 130,... 2.дан массив целых чисел, состоящий из 30 элементов. заполнить его с помощью датчика случайных чисел. Hайти: a) сумму отрицательных элементов б) количество тех элементов, значения которых положительны и не превосходят заданного числа АОтветы на вопрос
begin
var a:=106.Step(6).Take(15).ToArray; a.Println
end.
Результат
106 112 118 124 130 136 142 148 154 160 166 172 178 184 190
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
begin
var b:=ArrRandom(30,-50,50); b.Println;
var a:=ReadInteger('Введите число А:');
Writeln('Сумма отрицательных: ',b.Where(x->x<0).Sum);
Writeln('Cумма положительных, не больших ',a,', равна ',
b.Where(x->(x>0) and (x<=a)).Sum)
end.
Пример
-21 12 8 50 -47 35 45 -2 -30 -33 3 12 41 -29 8 2 -24 -44 -50 -2 -13 -32 33 -29 35 -43 20 -44 42 -3
Введите число А: 36
Сумма отрицательных: -446
Cумма положительных, не больших 36, равна 168
Кто хорошо разбирается в программировании?
В программировании есть множество людей, которые хорошо разбираются в этой области. Это могут быть профессиональные программисты, разработчики, инженеры по программному обеспечению и другие специалисты, которые имеют опыт и знания в программировании.
Программы на Паскале для задач:
1. Заполнение массива А[15] числами 106, 112, 118, 124, 130...
Вот пример программы на Паскале, которая заполняет массив А[15] числами 106, 112, 118, 124, 130 и так далее:
```pascal program FillArray; var A: array[1..15] of Integer; i, num: Integer; begin num := 106; for i := 1 to 15 do begin A[i] := num; num := num + 6; end; end. ```
2. Дан массив целых чисел, состоящий из 30 элементов. Заполните его с помощью датчика случайных чисел. Найдите: - а) сумму отрицательных элементов - б) количество элементов, значения которых положительны и не превосходят заданного числа А
Вот пример программы на Паскале, которая решает эту задачу:
```pascal program RandomArray; var A: array[1..30] of Integer; i, sum, count, num: Integer; begin Randomize; // Инициализация генератора случайных чисел sum := 0; count := 0; num := 100; // Заданное число А for i := 1 to 30 do begin A[i] := Random(201) - 100; // Генерация случайного числа от -100 до 100 if A[i] < 0 then sum := sum + A[i]; // Сумма отрицательных элементов if (A[i] > 0) and (A[i] <= num) then count := count + 1; // Количество положительных элементов, не превосходящих число А end; end. ```
В этой программе мы используем функцию `Randomize`, чтобы инициализировать генератор случайных чисел. Затем мы заполняем массив A случайными числами от -100 до 100 с помощью функции `Random(201) - 100`. Затем мы вычисляем сумму отрицательных элементов и подсчитываем количество положительных элементов, не превосходящих заданное число А.
Примечание: В приведенных примерах использован язык программирования Паскаль. Паскаль является одним из старых языков программирования, и его использование сегодня не так распространено, как раньше. Однако, если вам нужно написать программу на Паскале, вы можете использовать среду разработки, такую как Turbo Pascal, Delphi или Lazarus.
Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
