Вопрос задан 26.02.2019 в 11:47. Предмет Информатика. Спрашивает Огородова Юлия.

Составить программу нахождения количества букв "а" в тексте ( на языке Паскаль )

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Огнева Виктория.
Сделано 

(20 символов тоже тут)
0 0
Отвечает Иванов Дима.
Var
s:string;
i, m:integer;
begin
readln(s);
m:=0;
for i:=1 to length(s) do
if(s[i]='a') then m:=m+1;
writeln(m);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример простой программы на языке Pascal для подсчета количества букв "а" в тексте:

```pascal program CountA; var text: string; countA: integer; i: integer; begin // Ввод текста с клавиатуры writeln('Введите текст:'); readln(text);

// Инициализация счетчика букв "а" countA := 0;

// Проход по каждому символу в тексте for i := 1 to length(text) do begin // Если текущий символ - буква "а" (регистронезависимо), увеличиваем счетчик if (LowerCase(text[i]) = 'а') then countA := countA + 1; end;

// Вывод результата writeln('Количество букв "а" в тексте: ', countA);

// Ждем ввода, чтобы окно консоли не закрылось сразу readln; end. ```

Как работает программа:

1. Вводится текст с клавиатуры. 2. Инициализируется счетчик букв "а". 3. Проход по каждому символу в тексте. 4. Если текущий символ - буква "а" (регистронезависимо), увеличивается счетчик. 5. Выводится результат - количество букв "а" в тексте.

Обратите внимание, что программа учитывает букву "а" в любом регистре (регистронезависимо). Если вам нужно учесть только строчные или заглавные буквы "а", вы можете соответственно изменить условие внутри цикла.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос