1)Написать программу используя процедуру которая сортирует элементы целочисленного массива в
[1..n],n<или равно 25 по убыванию 2)Дни недели пронумерованы след образом:1 пон....7воскрес.Написать программу которая использует процедуру которая по известному номеру дня недели вернет его значение . 3)Написать программу которая использует функцию которая возвращает кол-во всех символов кроме пробелов содержащихся в строке символов (Решите все на базе PASCAL 7.0)Ответы на вопрос
Type
ty=array[1..25] of integer;
Var
n,i:integer;
ar:ty;
procedure sortbutmeh(var ar:ty;n:integer);
Var
i,j,c:integer;
begin
for i:=1 to n-1 do
for j:=i+1 to n do
if ar[i]<ar[j] then
begin
c:=ar[i];
ar[i]:=ar[j];
ar[j]:=c;
end;
end;
begin
randomize;
readln(n);
writeln('First array:');
for i:=1 to n do
begin
ar[i]:=random(100);
write(ar[i]:4);
end;
sortbutmeh(ar,n);
writeln;
writeln('Array after sortbutmeh()');
for i:=1 to n do
write(ar[i]:4);
end.
//2)
Var
n:integer;
procedure ned(n:integer);
begin
case n of
1:writeln('Понедельник');
2:writeln('Вторник');
3:writeln('Среда');
4:writeln('Четверг');
5:writeln('Пятница');
6:writeln('Суббота');
7:writeln('Воскресенье');
end;
end;
begin
readln(n);
ned(n);
end.
//3)
Var
s:string;
function lengthbutmeh(s:string):integer;
begin
while pos(' ',s)<>0 do
delete(s,pos(' ',s),1);
lengthbutmeh:=length(s);
end;
begin
readln(s);
writeln(lengthbutmeh(s));
end.
1) Вот пример программы на языке Pascal 7.0, которая сортирует элементы целочисленного массива в порядке убывания:
```pascal program SortArrayDescending;
const n = 10; // размер массива
type IntArray = array[1..n] of Integer;
var arr: IntArray; i, j, temp: Integer;
procedure SortDescending(var arr: IntArray); begin for i := 1 to n - 1 do begin for j := i + 1 to n do begin if arr[i] < arr[j] then begin temp := arr[i]; arr[i] := arr[j]; arr[j] := temp; end; end; end; end;
begin // Здесь можно инициализировать массив arr
SortDescending(arr);
// Вывод отсортированного массива for i := 1 to n do Write(arr[i], ' '); end. ```
2) Вот пример программы на языке Pascal 7.0, которая использует процедуру для получения значения дня недели по известному номеру:
```pascal program GetDayOfWeek;
var dayNumber: Integer;
procedure GetDayOfWeek(dayNumber: Integer; var dayOfWeek: String); begin case dayNumber of 1: dayOfWeek := 'понедельник'; 2: dayOfWeek := 'вторник'; 3: dayOfWeek := 'среда'; 4: dayOfWeek := 'четверг'; 5: dayOfWeek := 'пятница'; 6: dayOfWeek := 'суббота'; 7: dayOfWeek := 'воскресенье'; end; end;
begin // Здесь можно ввести номер дня недели dayNumber := 3;
// Получение значения дня недели var dayOfWeek: String; GetDayOfWeek(dayNumber, dayOfWeek);
// Вывод значения дня недели WriteLn(dayOfWeek); end. ```
3) Вот пример программы на языке Pascal 7.0, которая использует функцию для подсчета количества символов (кроме пробелов) в строке:
```pascal program CountCharacters;
function CountNonSpaceCharacters(str: String): Integer; var i, count: Integer; begin count := 0; for i := 1 to Length(str) do begin if str[i] <> ' ' then Inc(count); end; CountNonSpaceCharacters := count; end;
begin // Здесь можно ввести строку символов var inputString := 'Пример строки с пробелами';
// Вызов функции для подсчета количества символов (кроме пробелов) var count := CountNonSpaceCharacters(inputString);
// Вывод количества символов (кроме пробелов) WriteLn(count); end. ```
Убедитесь, что ваша среда разработки поддерживает язык Pascal 7.0 и выполните код в соответствующей среде.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
