
Cтроки. Паскаль.1.Задано слово - последовательность произвольных символов. Сделать программу, в
которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.)2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Ответы на вопрос

{Первая задача}
var
s, rez: string; // строки
i: integer; // целое число (счетчик)
begin
writeln('Введите строку:');
readln(s); //
for i := length(s) downto 1 do // просматриваем буквы, начиная с последней
rez := rez + s[i]; // прибавляем букву к результату
writeln(rez) // выводим результат
end.



Задача 1: Перевертыш слова
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет переворачивать заданное слово, то есть записывать символы в обратной последовательности.
Вот пример программы, которая решает эту задачу:
```pascal program ReverseWord; var word, reversedWord: string; i: integer; begin // Вводим слово write('Введите слово: '); readln(word); // Переворачиваем слово reversedWord := ''; for i := length(word) downto 1 do reversedWord := reversedWord + word[i]; // Выводим перевернутое слово writeln('Перевернутое слово: ', reversedWord); end. ```
Вы можете запустить эту программу в среде разработки PascalABC.NET или другой совместимой среде, чтобы увидеть результат.
Примечание: В данной программе предполагается, что вводимое слово не содержит пробелов или других разделителей. Если в слове присутствуют пробелы, то они будут также перевернуты и выведены вместе с остальными символами.
Задача 2: Поиск слов с заданным символом
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет выводить все слова, в которых есть заданный символ. Слова в данной задаче определяются как последовательность символов между пробелами, не содержащая пробелов внутри себя.
Вот пример программы, которая решает эту задачу:
```pascal program FindWordsWithCharacter; var sentence, word: string; character: char; i: integer; begin // Вводим предложение write('Введите предложение: '); readln(sentence); // Вводим символ write('Введите символ: '); readln(character); // Ищем слова с заданным символом word := ''; for i := 1 to length(sentence) do begin if sentence[i] <> ' ' then word := word + sentence[i] else begin if pos(character, word) > 0 then writeln(word); word := ''; end; end; // Проверяем последнее слово if pos(character, word) > 0 then writeln(word); end. ```
Вы можете запустить эту программу в среде разработки PascalABC.NET или другой совместимой среде, чтобы увидеть результат.
Примечание: В данной программе предполагается, что вводимое предложение состоит из слов, разделенных пробелами. Если в предложении присутствуют другие разделители, то программа может не работать корректно.



Конечно, вот пример программы на языке Pascal для выполнения задач, которые вы описали:
1. Программа для создания перевертыша заданного слова:
```pascal program ReverseWord;
var originalWord, reversedWord: string; i: integer;
begin // Вводим исходное слово write('Введите слово: '); readln(originalWord);
// Инициализируем переменную для перевернутого слова reversedWord := '';
// Формируем перевернутое слово for i := length(originalWord) downto 1 do reversedWord := reversedWord + originalWord[i];
// Выводим перевернутое слово writeln('Перевернутое слово: ', reversedWord);
end. ```
2. Программа для вывода всех слов, содержащих заданный символ:
```pascal program WordsWithCharacter;
var inputString, searchCharacter, currentWord: string; i: integer;
begin // Вводим символьную строку write('Введите строку: '); readln(inputString);
// Вводим символ, который будем искать в словах write('Введите символ для поиска: '); readln(searchCharacter);
// Инициализируем переменную для текущего слова currentWord := '';
// Обходим символы в строке for i := 1 to length(inputString) do begin // Если символ не пробел, добавляем его к текущему слову if inputString[i] <> ' ' then currentWord := currentWord + inputString[i] else begin // Проверяем, содержится ли заданный символ в текущем слове if pos(searchCharacter, currentWord) > 0 then writeln('Найдено слово: ', currentWord);
// Обнуляем текущее слово для следующей итерации currentWord := ''; end; end;
// Проверяем последнее слово в строке if (currentWord <> '') and (pos(searchCharacter, currentWord) > 0) then writeln('Найдено слово: ', currentWord);
end. ```
Обе программы предполагают, что ввод осуществляется с клавиатуры. Вы можете изменить программы в соответствии с вашими требованиями или внести коррективы в зависимости от конкретных условий задачи.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili