Вопрос задан 25.02.2019 в 23:40. Предмет Информатика. Спрашивает Смирнова Катя.

№3. Составьте программу в Pascal: С клавиатуры вводится трехзначное число. Определить является ли

сумма его цифр двухзначным и четным числом. Используйте: Ввод данных – Read. Вывод данных – Write. Проверка условий - If Then Else. Логическое «И» - AND
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Масленников Денис.
Program pascal;
var a, b1, b2, b3, c:integer;
begin
read(a);
b1:=a mod 10;
b2:=(a mod 100) div 10;
b3:=a div 100;
c:=b1+b2+b3;
if (c>=10) and (c<100) and (c mod 2=0)then
write('Yes')
else
write('No');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, который решает данную задачу:

```pascal program SumOfDigits;

var number, digit1, digit2, digit3, sum: integer;

begin // Ввод трехзначного числа с клавиатуры write('Введите трехзначное число: '); read(number);

// Разбиение числа на цифры digit1 := number div 100; digit2 := (number div 10) mod 10; digit3 := number mod 10;

// Вычисление суммы цифр sum := digit1 + digit2 + digit3;

// Проверка условия: сумма цифр должна быть двузначным и четным числом if (sum >= 10) and (sum <= 99) and (sum mod 2 = 0) then writeln('Сумма цифр является двузначным и четным числом.') else writeln('Сумма цифр не является двузначным и четным числом.');

end. ```

Как работает программа:

1. Вводится трехзначное число. 2. Число разбивается на цифры (digit1, digit2, digit3). 3. Вычисляется сумма цифр. 4. Проверяется условие: сумма цифр должна быть двузначным и четным числом. 5. Выводится соответствующее сообщение.

Примечание: В данной программе предполагается, что вводимое число всегда трехзначное. Если нужно обрабатывать случаи ввода чисел с другим количеством цифр, программа должна быть дополнена соответствующими проверками.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос