На паскале нужно решить задачи 1.Задано трехзначное число. Составьте программу, с помощью которой
определите произведение кубов цифр этого числа. 2.Задано трехзначное число. Составьте программу, с помощью которой определите , равняются ли в нем крайние числа.Ответы на вопрос
var
a,e,d,s,p: integer;
begin
p:=1;
writeln ('введи трехзначное число');
read (a);
e:= (a mod 10);
s:=(a div 100);
d:=s*100-e;
p:=s*s*s*d*d*d*e*e*e;
writeln ('произведение кубов цифр числа равно',p);
if e=s then writeln ('первая цифра числа равна последней')
else
writeln ('первая цифра числа не равна последней');
end.
Решение задач на Паскале
1. Задача: Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа.
Для решения этой задачи на Паскале можно использовать следующий код:
```pascal program CubeProduct; var number, digit, cubeProduct: integer; begin write('Введите трехзначное число: '); readln(number); cubeProduct := 1; // Разделяем число на цифры и находим произведение кубов цифр digit := number div 100; // первая цифра cubeProduct := cubeProduct * digit * digit * digit; digit := (number div 10) mod 10; // вторая цифра cubeProduct := cubeProduct * digit * digit * digit; digit := number mod 10; // третья цифра cubeProduct := cubeProduct * digit * digit * digit; writeln('Произведение кубов цифр числа: ', cubeProduct); end. ```
2. Задача: Задано трехзначное число. Составьте программу, с помощью которой определите, равняются ли в нем крайние числа.
Для решения этой задачи на Паскале можно использовать следующий код:
```pascal program CheckEndDigits; var number, firstDigit, lastDigit: integer; begin write('Введите трехзначное число: '); readln(number); firstDigit := number div 100; // первая цифра lastDigit := number mod 10; // третья цифра if firstDigit = lastDigit then writeln('Крайние числа равны') else writeln('Крайние числа не равны'); end. ```
Обратите внимание, что в обоих программах пользователю предлагается ввести трехзначное число, после чего программа выполняет необходимые вычисления и выводит результат на экран.
Примечание: Предоставленные коды являются примерами и могут быть доработаны или оптимизированы в зависимости от конкретных требований или предпочтений программиста.
Источники: -(https://www.you.com) (название источника не указано) -(https://www.you.com) (название источника не указано)
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
