Вопрос задан 25.02.2019 в 15:10. Предмет Информатика. Спрашивает Хайрат Лаура.

Напишите программу, которая получает натуральные числа A и B (A<B) и выводит все простые числа в

интервале от A до B.На языке C.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Филатова Алина.
#include<stdio.h>
#include<conio.h>
#include<math.h>

bool simpl(int n)
 { 
   int k=0;
   for (int i=2; i<=sqrt(n); i++)
   if ((n % i)==0)   {  k=1;  break; }
   if (k==0)  return true;
   else return false;
 }

int main() { 
     int a,b;
     printf("A = ");  scanf("%i",&a);
     printf("B = ");  scanf("%i",&b);
     for (int i=a; i<=b; i++)
       if (simpl(i)) printf("%i  ",i);
     printf("\n");
     getch();
    return(0);
}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот программа, написанная на языке C, которая выводит все простые числа в заданном интервале от A до B:

```c #include

int isPrime(int num) { if (num <= 1) { return 0; } for (int i = 2; i * i <= num; i++) { if (num % i == 0) { return 0; } } return 1; }

int main() { int A, B; printf("Введите число A: "); scanf("%d", &A); printf("Введите число B: "); scanf("%d", &B); printf("Простые числа в интервале от %d до %d:\n", A, B); for (int i = A; i <= B; i++) { if (isPrime(i)) { printf("%d ", i); } } return 0; } ```

Эта программа сначала определяет функцию `isPrime`, которая проверяет, является ли число простым. Затем в функции `main` пользователю предлагается ввести числа A и B. Программа затем выводит все простые числа в заданном интервале от A до B.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос