Информатика 5. Напишите программу, которая вводит трёхзначное число и десятичную цифру.
Определить, входит ли эта цифра в десятичную запись введённого числа.Ответы на вопрос
var
a,b,i: integer;
f:boolean;
begin
f:=false;
readln(a);
readln(b);
for i:=1 to 3 do begin
if a mod 10 = b then f :=true;
a:=a div 10;
end;
if f then writeln('входит')
else writeln('Не входит');
end.
Тестовое решение
для a=123 и b =3
123
3
входит
Для а = 123 и b = 5
123
5
Не входит
Программа для определения вхождения десятичной цифры в трехзначное число
Для решения данной задачи, напишем программу на языке программирования Python. В программе мы будем использовать встроенные функции для работы с числами и строками.
```python # Ввод трехзначного числа и десятичной цифры number = int(input("Введите трехзначное число: ")) digit = int(input("Введите десятичную цифру: "))
# Преобразование числа в строку для проверки вхождения цифры number_str = str(number)
# Проверка вхождения цифры в число if str(digit) in number_str: print("Цифра", digit, "входит в число", number) else: print("Цифра", digit, "не входит в число", number) ```
Программа сначала запрашивает у пользователя трехзначное число и десятичную цифру. Затем она преобразует число в строку и проверяет, содержит ли эта строка введенную цифру. Если цифра содержится в числе, программа выводит сообщение о том, что цифра входит в число. В противном случае, программа выводит сообщение о том, что цифра не входит в число.
Например, если пользователь вводит число 123 и цифру 2, программа выведет сообщение "Цифра 2 входит в число 123".
Примечание: В данном ответе использованы сниппеты из следующих источников: -: Сниппет из источника "8. .", который содержит информацию о вводе числа и цифры. -: Сниппет из источника "IX", который содержит информацию о преобразовании числа в строку и проверке вхождения цифры в строку числа.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
