Вопрос задан 24.02.2019 в 08:25. Предмет Информатика. Спрашивает Сергеев Лёха.

Помогите написать программу(С++) Даны два числа. Найти среднее арифметическое кубов этих чисел и

среднее геометрическое модулей этих чисел. Исходные данные разместить на двух строках. Выдать на печать информацию в виде: а) пропустить три строки б) в центре листа напечатать ответ в виде: СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ КУБОВ ЧИСЕЛ X и Y: (X^3+Y^3)/2=..... СРЕДНЕЕ ГЕОМЕТРИЧЕСКОЕ МОДУЛЕЙ ЧИСЕЛ: (Abs(X)*abs(Y))/2=..... *********************** в) ИСХОДНЫЕ ДАННЫЕ X=..... Y=..... ***********************
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Толмачёв Артём.
#include <iostream>
#include <math.h>
#include <cstdlib>
using namespace std;

int main() {
setlocale(LC_ALL, "Russian");
int x, y;
cout << "x=";
cin >> x;
cout << "y=";
cin >> y;
cout << "\n\n\n"
<< "СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ КУБОВ ЧИСЕЛ X и Y:\n"
<< "(X^3+Y^3)/2="
<< ( ( pow(x,3) + pow(y,3) ) / 2 )
<< '\n'
<< "СРЕДНЕЕ ГЕОМЕТРИЧЕСКОЕ МОДУЛЕЙ ЧИСЕЛ:\n"
<< "(abs(X)*abs(Y))/2="
<< ( ( abs(x) * abs(y) ) / 2 )
<< "\n********************\n"
<< "ИСХОДНЫЕ ДАННЫЕ\n"
<< "X=" << x << '\n'
<< "Y=" << y << '\n'
<< "********************";
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам написать программу на C++, которая решает вашу задачу. Вот пример кода, который вы можете использовать:

```c++ #include #include using namespace std;

int main() { // Объявляем две переменные для хранения чисел double x, y; // Считываем числа с клавиатуры cout << "Введите первое число: "; cin >> x; cout << "Введите второе число: "; cin >> y; // Вычисляем среднее арифметическое кубов чисел double avg_cube = (pow(x, 3) + pow(y, 3)) / 2; // Вычисляем среднее геометрическое модулей чисел double avg_abs = sqrt(abs(x) * abs(y)); // Выводим результаты на экран cout << "\n\n\n"; // Пропускаем три строки cout << "СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ КУБОВ ЧИСЕЛ X и Y: (X^3 + Y^3) / 2 = " << avg_cube << "\n"; // Выводим среднее арифметическое кубов cout << "СРЕДНЕЕ ГЕОМЕТРИЧЕСКОЕ МОДУЛЕЙ ЧИСЕЛ: (Abs(X) * Abs(Y)) / 2 = " << avg_abs << "\n"; // Выводим среднее геометрическое модулей cout << "***\n"; // Выводим разделитель cout << "ИСХОДНЫЕ ДАННЫЕ X = " << x << " Y = " << y << "\n"; // Выводим исходные данные cout << "***\n"; // Выводим разделитель return 0; } ```

Вы можете запустить этот код в своем браузере, используя онлайн компилятор, например, [этот](https://www.w3schools.com/cpp/default.asp). Если вы хотите узнать больше о языке C++, вы можете прочитать один из этих учебников: [W3Schools](https://cplusplus.com/doc/tutorial/), [C++ Users](https://www.learncpp.com/), [LearnCpp.com](https://www.programiz.com/cpp-programming) или [Programiz]. Надеюсь, это вам поможет.

0 0

Последние заданные вопросы в категории Информатика

Задать вопрос