Составить программы в паскале: 1. Составить алгоритм и программу для нахождения значения выражения:
Y=(a mod b)*(c div b) 2. Напишите программу для вычисления выражения: X=(а + (d - 12) *3) * (с - 5*k), значения переменных а, d, с и k вводятся с клавиатуры.Ответы на вопрос
Var a,b,c : Integer;
Begin
Readln(a,b,c);
Writeln((a mod b)*(c div b));
end.
2.
Var a,d,c,k : Integer;
Begin
Readln(a,d,c,k);
Writeln((a+(d-12)*3)*(c-5*k));
end.
Программа для нахождения значения выражения Y=(a+mod+b)*(c+div+b)
```pascal program ExpressionY; var a, b, c, Y: integer; begin writeln('Введите значения переменных a, b и c:'); readln(a, b, c); Y := (a mod b) * (c div b); writeln('Значение выражения Y = ', Y); end. ```
Объяснение программы: - Программа запрашивает значения переменных a, b и c с помощью функции `readln`. - Затем программа вычисляет значение выражения Y=(a+mod+b)*(c+div+b) и сохраняет его в переменную Y. - Наконец, программа выводит значение выражения Y на экран с помощью функции `writeln`.
Программа для вычисления значения выражения X=(а+++(d+-+12)*3)*+(с+-+5*k)
```pascal program ExpressionX; var a, d, c, k, X: integer; begin writeln('Введите значения переменных a, d, c и k:'); readln(a, d, c, k); X := (a + (d - 12) * 3) * (c - 5 * k); writeln('Значение выражения X = ', X); end. ```
Объяснение программы: - Программа запрашивает значения переменных a, d, c и k с помощью функции `readln`. - Затем программа вычисляет значение выражения X=(а+++(d+-+12)*3)*+(с+-+5*k) и сохраняет его в переменную X. - Наконец, программа выводит значение выражения X на экран с помощью функции `writeln`.
Примечание: Обратите внимание, что в выражении X используется оператор "++", который не является допустимым в языке Pascal. Если вы хотите увеличить значение переменной на 1, вы можете использовать оператор инкремента "a := a + 1" или "a += 1".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
