
Помогите пожалуйста написать программу си++ задан массив целых чисел вычислить сумму отрицательных
элементов этого массива и определить их количество

Ответы на вопрос

using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}
for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}



Решение задачи на C++
Для вычисления суммы отрицательных элементов массива и определения их количества на C++ можно написать следующую программу:
```cpp
#include
int main() { int arr[] = {1, -2, 3, -4, 5, -6, 7, -8, 9, -10}; int sum = 0; int count = 0;
for (int i = 0; i < 10; i++) { if (arr[i] < 0) { sum += arr[i]; count++; } }
cout << "Сумма отрицательных элементов: " << sum << endl; cout << "Количество отрицательных элементов: " << count << endl;
return 0; } ```
В этой программе мы объявляем массив `arr` и инициализируем его значениями. Затем мы проходим по массиву, проверяя каждый элемент на отрицательность. Если элемент отрицательный, мы добавляем его к сумме и увеличиваем счетчик отрицательных элементов. В конце программы выводим сумму и количество отрицательных элементов.
Пример вывода: ``` Сумма отрицательных элементов: -30 Количество отрицательных элементов: 5 ```


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili