2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина
угла между этими сторонами. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление площади треугольника. Введите (через пробел) длины двух сторон (см) треугольника = 25 17 Введите величину угла между сторонами треугольника = 30 Площадь треугольника: 106.25 кв.см.Ответы на вопрос
a,b,alpha,s:real;
begin
writeln('Вычисление площади треугольника');
writeln('Введите (через пробел) длины двух сторон (см) треугольника');
readln(a,b);
writeln('Введите величину угла (градус) между сторонами треугольника');
readln(alpha);
alpha:=DegToRad(alpha);
writeln('Площадь треугольника: ',0.5*a*b*sin(alpha),' кв.см.')
end.
Тестовое решение:
Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
25 17
Введите величину угла (градус) между сторонами треугольника
30
Площадь треугольника: 106.25 кв.см.
Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
11 16.3
Введите величину угла (градус) между сторонами треугольника
39
Площадь треугольника: 56.4185730576179 кв.см.
Я могу помочь вам с написанием программы на языке Python, которая вычисляет площадь треугольника по формуле: $$S = \frac{1}{2}ab\sin C$$, где $a$ и $b$ - длины двух сторон треугольника, а $C$ - угол между ними. Вот пример кода, который реализует эту формулу:
```python # Импортируем модуль math для использования функции sin import math
# Вводим длины двух сторон треугольника через пробел a, b = map(float, input("Введите (через пробел) длины двух сторон (см) треугольника = ").split())
# Вводим величину угла между сторонами треугольника в градусах C = float(input("Введите величину угла между сторонами треугольника = "))
# Переводим угол из градусов в радианы C = math.radians(C)
# Вычисляем площадь треугольника по формуле S = 0.5 * a * b * math.sin(C)
# Выводим результат на экран с двумя знаками после запятой print("Площадь треугольника: {:.2f} кв.см.".format(S)) ```
Вы можете запустить этот код в онлайн-редакторе Python, например, [здесь]. Надеюсь, это вам поможет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
