Вопрос задан 20.02.2019 в 07:24. Предмет Информатика. Спрашивает Фомин Александр.

. Составьте программу для вычисления площади трапеции при известных основаниях и высоте.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Власова Юлия.
Var a,b,h:real;
begin
   write('Vvedita osnovaniya:');
   read(a,b);
   write('Vvedite visotu:');
   read(h);
   writeln('S=',(a+b)/2*h);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для вычисления площади трапеции по известным основаниям и высоте можно использовать следующую программу на языке Python:

``` # Ввод оснований и высоты osnovanie1 = float(input("Введите длину первого основания: ")) osnovanie2 = float(input("Введите длину второго основания: ")) visota = float(input("Введите высоту трапеции: "))

# Вычисление площади трапеции ploshad = (osnovanie1 + osnovanie2) * visota / 2

# Вывод результата print("Площадь трапеции равна", ploshad) ```

Программа сначала запрашивает у пользователя длины оснований и высоту трапеции. Затем, используя формулу для вычисления площади трапеции, программа выполняет соответствующие вычисления и сохраняет результат в переменной `ploshad`. Наконец, программа выводит полученное значение площади на экран.

Пример использования программы: ``` Введите длину первого основания: 5 Введите длину второго основания: 7 Введите высоту трапеции: 4 Площадь трапеции равна 24.0 ```

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос