Помогите составить программу в Pascal ABC ! Дано натуральное число 1)Программа, которая находит
сумму цифр этого числа 2)которая определяет, что число начинается и заканчивается одной и той же цифройОтветы на вопрос
begin
read (n);
b:= n mod 10;
while n>0 do
begin
if n div 10 = 0 then
a:= n mod 10;
sum:= sum + (n mod 10);
n:= n div 10;
end;
writeln (sum);
if a = b then write ('First digit = Last Digit')
else
write ('First digit <> Last Digit');
end.
Программа для нахождения суммы цифр числа
Для нахождения суммы цифр данного числа в Pascal ABC можно использовать следующую программу:
```pascal program SumOfDigits; var number, digit, sum: integer; begin writeln('Введите натуральное число:'); readln(number); sum := 0; while number > 0 do begin digit := number mod 10; sum := sum + digit; number := number div 10; end; writeln('Сумма цифр числа:', sum); end. ```
В этой программе мы считываем натуральное число с клавиатуры и затем с помощью цикла while находим сумму его цифр. Каждую цифру мы получаем с помощью операции остатка от деления на 10 (number mod 10), а затем добавляем ее к общей сумме (sum). Затем число number делится на 10 (number div 10), чтобы перейти к следующей цифре. Процесс продолжается до тех пор, пока число number не станет равным 0. В конце программы выводится полученная сумма цифр числа.
Программа для определения, что число начинается и заканчивается одной и той же цифрой
Для определения, начинается и заканчивается ли число одной и той же цифрой, можно использовать следующую программу:
```pascal program SameFirstAndLastDigit; var number, firstDigit, lastDigit: integer; begin writeln('Введите натуральное число:'); readln(number); firstDigit := number mod 10; while number >= 10 do begin number := number div 10; end; lastDigit := number; if firstDigit = lastDigit then writeln('Число начинается и заканчивается одной и той же цифрой') else writeln('Число не начинается и не заканчивается одной и той же цифрой'); end. ```
В этой программе мы считываем натуральное число с клавиатуры и затем с помощью операций остатка от деления и деления на 10 находим первую и последнюю цифры числа. Первая цифра получается с помощью операции остатка от деления на 10 (number mod 10), а последняя цифра - путем последовательного деления числа на 10 (number div 10) до тех пор, пока оно не станет меньше 10. Затем мы сравниваем первую и последнюю цифры и выводим соответствующее сообщение.
Обратите внимание: В обоих программах предполагается, что пользователь вводит только натуральные числа. Если нужно обрабатывать и отрицательные числа, то необходимо внести соответствующие изменения в программу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
