Вопрос задан 18.02.2019 в 07:04. Предмет Информатика. Спрашивает Пухова Диана.

Написать программу на языке паскаль. даны стороны прямоугольника a и b. найти его периметр P=2*(a+b)

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Румянцева Наталья.
Uses crt; 
var a, b, S, P:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
S:=a*b; P:=2*(a+b);
write('S=',S,' ','P=',P);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Паскаль, которая находит периметр прямоугольника по заданным сторонам a и b:

```pascal program CalculatePerimeter; var a, b, P: integer; begin writeln('Введите стороны прямоугольника:'); write('a: '); readln(a); write('b: '); readln(b); P := 2 * (a + b); writeln('Периметр прямоугольника: ', P); end. ```

В этой программе мы объявляем переменные `a`, `b` и `P` типа `integer`. Затем мы запрашиваем у пользователя ввод значений для сторон `a` и `b` с помощью `readln`. Далее мы вычисляем периметр прямоугольника по формуле `P = 2 * (a + b)` и выводим результат с помощью `writeln`.

Примечание: При написании программы на языке Паскаль важно убедиться, что вы используете правильный синтаксис и правильно объявляете переменные. Также обратите внимание, что в данном примере мы предполагаем, что пользователь будет вводить целочисленные значения для сторон прямоугольника. Если вам нужно работать с десятичными числами, вам может потребоваться использовать другой тип данных, например `real` или `double`.

Надеюсь, это поможет вам написать программу на языке Паскаль для вычисления периметра прямоугольника! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос