
Программирование.Язык Паскаль.Помогите пожалуйста,нужно нарисовать блок схемы и написать
программы1)Дана строка и буква. Определить сколько слов в строке начинается на эту букву.Вывести эти слова.2)Составить программу,которая в заданном слове с дефисом меняет местами части до и после дефиса

Ответы на вопрос

var
s,a,b:string;
begin
writeln('Введите слово: '); readln(s);
b:=Copy(s,1,Pos('-',s)-1);
a:=Copy(s,Pos('-',s)+1,Length(s)-Length(b));
writeln(a,'-',b);
end.



1) Для решения данной задачи можно использовать язык программирования Паскаль. Ниже приведена программа, которая решает задачу:
```pascal program CountWordsStartingWithLetter; var str, letter, word, currentWord: string; i, start, count: integer; begin writeln('Введите строку:'); readln(str); writeln('Введите букву:'); readln(letter); str := str + ' '; // добавляем пробел в конце строки, чтобы обработать последнее слово count := 0; // счетчик слов currentWord := ''; for i := 1 to length(str) do begin if str[i] <> ' ' then currentWord := currentWord + str[i] else begin if (currentWord <> '') and (currentWord[1] = letter) then begin count := count + 1; writeln(currentWord); end; currentWord := ''; end; end; writeln('Количество слов, начинающихся на букву ', letter, ': ', count); end. ```
2) Для решения второй задачи также можно использовать язык программирования Паскаль. Ниже приведена программа, которая меняет местами части слова до и после дефиса:
```pascal program SwapPartsBeforeAndAfterHyphen; var word, part1, part2: string; hyphenPos: integer; begin writeln('Введите слово с дефисом:'); readln(word); hyphenPos := pos('-', word); part1 := copy(word, 1, hyphenPos - 1); part2 := copy(word, hyphenPos + 1, length(word) - hyphenPos); writeln('Результат замены:'); writeln(part2, '-', part1); end. ```
Обе программы можно скомпилировать и запустить в среде разработки, поддерживающей язык Паскаль.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili