Вопрос задан 14.02.2019 в 05:45.
Предмет Информатика.
Спрашивает Тебенькова Марина.
Напишите программу , которая сортирует массив, а затем находит максимальное из чисел ,
встречающихся в массиве несколько раз. ПаскальОтветы на вопрос
Отвечает Тян Катя.
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
Sort(a);
var v:=a.Last;
var found:=False;
for var i:=a.High-1 downto 0 do
if a[i]=v then begin Writeln(v); found:=True; break end
else v:=a[i];
if not found then Writeln('В массиве нет дубликатов')
end.
Пример
n= 15
-13 11 1 -19 14 2 20 -15 14 -10 -15 8 4 -2 -13
14
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
Sort(a);
var v:=a.Last;
var found:=False;
for var i:=a.High-1 downto 0 do
if a[i]=v then begin Writeln(v); found:=True; break end
else v:=a[i];
if not found then Writeln('В массиве нет дубликатов')
end.
Пример
n= 15
-13 11 1 -19 14 2 20 -15 14 -10 -15 8 4 -2 -13
14
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
