Вопрос задан 13.02.2019 в 06:16.
Предмет Информатика.
Спрашивает Добровольский Олег.
Составьте программу,которая заполняет массивa[1..10] случайными целыми числами в диапазоне от 1 до
10,затем меняет местами первый элемент со вторым,третий с четвёрым и т.д.Ответы на вопрос
Отвечает Крашенинников Тимур.
Const n=10; mi=1; ma=10;
var a:array[1..n] of integer; i:integer;
begin
for i:=1 to n do begin a[i]:=random(ma-mi+1)+mi; write(a[i],' ') end;
writeln;
for i:=1 to n div 2 do begin a[2*i]:=a[2*i]+a[2*i-1]; a[2*i-1]:=a[2*i]-a[2*i-1]; a[2*i]:=a[2*i]-a[2*i-1] end;
for i:=1 to n do write(a[i],' ')
end.
var a:array[1..n] of integer; i:integer;
begin
for i:=1 to n do begin a[i]:=random(ma-mi+1)+mi; write(a[i],' ') end;
writeln;
for i:=1 to n div 2 do begin a[2*i]:=a[2*i]+a[2*i-1]; a[2*i-1]:=a[2*i]-a[2*i-1]; a[2*i]:=a[2*i]-a[2*i-1] end;
for i:=1 to n do write(a[i],' ')
end.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
