
Вопрос задан 28.04.2018 в 08:13.
Предмет Информатика.
Спрашивает Скалкин Владислав.
6. Составить алгоритм и написать программу вычисления суммы и среднего значения только
отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел.N не больше 10

Ответы на вопрос

Отвечает Оразбай Ахмедияр.
Var a:array[1..100] of integer;
i,n,s,k:integer;
begin
s:=0; k:=0;
write('Введите кол-во чисел: '); readln(n);
write('Введите числа: ');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<0 then begin
s:=s+a[i];
inc(k);
end;
if k<>0 then
begin writeln('Ср.знач. отрицательных чисел: ',s/k);
writeln('Сумма отрицательных чисел: ',s); end
else writeln('Отрицательных членов нет');
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili