
Вопрос задан 27.04.2018 в 14:46.
Предмет Информатика.
Спрашивает Муравьев Данил.
Помоги пожалуйста решить задачу на Paskal. Чтобы открыть секретный сейф, агент 007 решил набирать в
возрастающем порядке все трехзначные числа, в записи которых нет одинаковых цифр. Составить программу, которая бы печатала все такие числа. Определить, сколько времени потребуется ему в худшем случае для вскрытия сейфа, если для набора одного числа он тратит 2с?

Ответы на вопрос

Отвечает Аксенова Екатерина.
Program test ;
Var
a:integer;
Begin
For i:=0 to 9 do begin
For i1:=0 to 9 do begin
For i2:=0 to 9 do begin
If (i<>i1) and (i1<>i2) and (i<>i2) then begin
writeln(" Комбинация введенная агентом 007 - ",i*100+i1*10+i2);
a:=a+2;
End;
End;
End;
Writeln(" В ХУДШЕМ случае он затратит на подбор пароля. ", a div 60,"мин. ",a mod 60,"сек. ") ;
End.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili